Dafny on windows 7

Mar 16, 2015 at 3:35 PM
Edited Mar 16, 2015 at 3:37 PM
Hello! I try to run the latest Dafny release 1.9.1 on Windows 7 VM, that I downloaded from https://www.modern.ie/en-us/virtualization-tools
It comes pretty empty, so I've installed .Net 4.5 there, also from MS website.

I downloaded Dafny.zip and extracted it to C:\Users\IEUser\Downloads\Dafny
Now running .\Dafny.exe throws an exception "Operation is not supported." for loading an assembly from a network location, which seems disabled by default in Win7 or .Net 4.5
The error report contains the link go.microsoft.com/fwlink/?LinkId=155569
It suggests to add some configuration parameter to a configuration file.

Where can I find that file?
I tried to create Dafny.exe.config, and put to suggested xml configuration there - it didn't work out. I tried to modify some of msbuild.exe.config's found on my disk C: (one from Microsoft.NET I actually managed to modify with Administrator's privileges, others are forbidden from modification even by Administrator).

Who else had this problem? What is the magical config file, that you should update in such cases?

I'm not an experienced Windows user, sorry if the question seem obvious
Apr 19, 2015 at 4:02 PM

For to run Dafny in command line I downloaded Dafny.zip and Boogie.Zip and I uncompressed it in C:\ .
In this way I think that you can resolve the problem.

Apr 20, 2015 at 8:33 AM
Apr 20, 2015 at 9:49 AM
Thank you, lexicalscope. The first link turned out to have the exact solution : before extracting the zip file, fire up the properties dialog and press "Unlock" button.